SDStudio Alpha (WIP) Version 0.0.9 Release

Update notifications and future news will be posted here
User avatar
Serkan
Developer
Developer
Posts: 207
Joined: Thu Jul 04, 2013 8:44 pm
Location: Windows.h
Contact:

SDStudio Alpha (WIP) Version 0.0.9 Release

Post by Serkan »

Today first WIP version of SDStudio is ready to distribute
Alpha version test program members will receive a download link

As of the name suggests ,this is a Work In Progress version and it is totally IDE focused
Therefore ,you cannot build anything useful with this version , You can only build an empty project with some customizations
Such as : 32Bits vs 64Bits ,

Only a standard main window options exist ,you can create as many windows as you want but you can only display main window
There is only Button control ,Other control icons there for testing purposes and they are inactive
Actually there were more controls exist but , Due to buil-in theme support possibilities and *maybe* an auto-multilingual gui support
We are using a single control to test everything and then create new controls based on these possible options

Much more options will be added to controls (current Window and Button control contains only a few options)

Project settings dialog is almost empty ,there is a reson for this , and we have not forgot anything
They will be added in the next versions

Application preferences dialog is empty, same reason applies to this just like the project settings dialog

Some options are either disabled or hidden , such as import/export template , Publish button etc..
All of them will be available in the next versions

Script editor still needs some work but they will be added based on the new controls ,and your requests
Function wizard contains only a few functions for testing , Like mentioned above you can not make anything useful with this version.
Maybe a few weeks later

Script editor uses an XML file based color theme (syntax highlighting) a theme is automatically selected based on the current application theme
This will be optional , auto by app theme , custom theme specified by user ,or any installed theme
Theme files can be found in the following path , this might be different on your computer

Code: Select all

C:\Users\UserName\AppData\Roaming\SDStudio\Editor Themes
They all decimal color values , or size in pixels ,so you can easily edit any theme file manually
Curent themes might appear incorrectly , because current themes were hastily created
If you have a better version suggestion for a specific theme or a custom theme then please do not hesitate to send us

The application debugger does not function properly , because of the Lua's error reporting logic
This will be fixed in the next versions , this might require a modified Lua build

You can only static link with the Lua library , this will be optional in the next versions , so you will be anle to select linkage of the Lua library
Curent version of the Lua in SDStudio is 5.3.4

Working events in the test environment are : Button:OnLefClick and Window:OnInitDialog
Working Functions are :

Code: Select all

Application:ShowMessage("Title","Message");
SDStudio will always build Unicode applications , this will not change in future

All of the Visual Designer options will be available in the next versions , such as (Grid,Snap etc..)

A toolbar editor ,a menu editor ,an image collection will be added

Currently scripts are encrypted with a simple algorithm ,and embedded with application binary in debug (preview mode)
A more advanced encryption will be applied in publish mode after Lua byte code compilation ,so this will provide a double encryption
In debug mode scripts will be added as they appear in the editor without any modifications (due to debugging requirements (line no etc..)
Even if Lua does not report error line correctly

Finally ,The next steps of the project will go faster because most of the stuff was already exist as an old SDStudio draft or as a standalone extension , from the old p-l-u-g-i-n-s etc..
gva
Registered User
Posts: 7
Joined: Thu Jan 18, 2018 9:38 pm

Post by gva »

startup screen: hard to get to the design environment... Not sure how I can create a new project.
I put a name, and that just triggers the creation of a folder. Can't seem to go beyond that point. I'm probably missing the obvious...
User avatar
Serkan
Developer
Developer
Posts: 207
Joined: Thu Jul 04, 2013 8:44 pm
Location: Windows.h
Contact:

Post by Serkan »

gva wrote: Mon Jan 29, 2018 9:11 pm startup screen: hard to get to the design environment... Not sure how I can create a new project.
I put a name, and that just triggers the creation of a folder. Can't seem to go beyond that point. I'm probably missing the obvious...
Hi
in the new project screen , entering a project name and pressing the Create button should create a project and load it
By default , projects created in the Documents\SDStudio\Projects

Is the problem still persist ?

IDE should show an error message if it fails to create project with a reason

Do you see any error message ?
gva
Registered User
Posts: 7
Joined: Thu Jan 18, 2018 9:38 pm

Post by gva »

when I press Create, nothing happens. A folder is created and that's it. There is not sdsproj in that folder. And I cannot do anything else then press ESC. But I'm not arriving in a window where I can write code or create a UI.
User avatar
Serkan
Developer
Developer
Posts: 207
Joined: Thu Jul 04, 2013 8:44 pm
Location: Windows.h
Contact:

Post by Serkan »

Can you try a different path as the destination
This might be due to a unicode character in user name
please try with a simple path for example

Code: Select all

C:\Test
gva
Registered User
Posts: 7
Joined: Thu Jan 18, 2018 9:38 pm

Post by gva »

Same problem. The project name become a sub folder in the Project Location path. And then... nothing.
I'm using Win10 Home 64bit.
gva
Registered User
Posts: 7
Joined: Thu Jan 18, 2018 9:38 pm

Post by gva »

I found the cause and the solution: when I run the tool as ADMIN, all works as expected.
gva
Registered User
Posts: 7
Joined: Thu Jan 18, 2018 9:38 pm

Post by gva »

Tested this release and all that should be working is working (if you run the tool in Admin mode).

One thing I don't like, is the checkerboard grid. It gives me a headache, it makes me dizzy.
I would suggest to make it just gray or white.
User avatar
BadKaiPanda
Registered User
Posts: 93
Joined: Fri Jun 14, 2013 8:49 pm

Post by BadKaiPanda »

Tomorrow I will get a cup of coffee on the go and give this the best look over I can.
BunnyHop CDD Obscurer Post | Home Page
User avatar
BadKaiPanda
Registered User
Posts: 93
Joined: Fri Jun 14, 2013 8:49 pm

Post by BadKaiPanda »

Just had a quick test and the settings pages are really bad, they flicker like they on some kind of drug lol
I see we can only create on button so far but like you said this is about the IDE, but showing all the others when they don't work
shows me that it's not dynamic, The UI themes don't seem to offer a nice UI away from the shitty MS crap but that's me been picky.

Tool window also seems buggy the close button is a tool window but the top bar is not, not sure if that's a bug with windows 10 or not
Image

The open window is two big PLEASE ditch the metro look, Windows is shit with metro styling lets not let Microsoft win making people use this style it's made that hole open page feel childish.

I don't see why you have included all the social media links in the app, that also makes me feel your more bothered about the name rather then then the tool, this is my VIEW I am not saying this is the case, this is what I feel for any app adding social media links to any app, I find that bad practice myself.

I would like to see a option to move around the work space I don't like been stick in the left top corner I like the freedom to move it about.

When the app is active there is a strange blue box around the button this is only when the window is active.
Image: http://icecream.me/39f2d5e63922f80b62b65351cfd41b3e (Your site didn't like the image size)

The IDE icon will need some work also it feels like one of she loves me or hugs me sweets lol

Part from the styles and the flickering in the settings page when changing a tab, I think it's to do with our your drawing the items to the page it's all working fine I been able to rag it about and no crash's

The app demo does say open when you close the IDE tho, maybe have it close the app when you close the IDE.

I love the note system that will be really helpful when you need to remember to do something later.

The scripting window is also two busy it makes me feel like I have opened a hole new app, this is very confusing to anyone that didn't know this kind of app, the scripting window needs simpler icons and view, it should be more like a note pad like window, Also I feel we should be able to code editing in the main UI so a new tab with the scripting page on it also if we pick to without the need a new window.

Is there anything else you want testing ?
BunnyHop CDD Obscurer Post | Home Page
Locked